Go Back   WowAce Forums > Official Addon Threads > Unit Frames
Unit Frames ag_UnitFrames, Grid, Pitbull, X-Perl, etc., and modules

Reply
 
Thread Tools
Old 10-07-2008   #1
Zeksie
Senior Member
 
Join Date: Mar 2006
Posts: 292
Default X-Perl Thread

The X-Perl* thread, since it's missing apparently. Try to keep complaints to a maximim of 2 pages.

Regards,
Zek

* the non-ace UnitFrame 'gasp'.
Zeksie is offline   Reply With Quote
Old 10-07-2008   #2
tenchu
Junior Member
 
Join Date: May 2007
Posts: 70
Default Re: X-Perl Thread

No complaints here!! Sweet mod.

One thing is that it's possible to make the party player frame as 2X2, 1X4, and 4X1? No biggy if it's no possible.
tenchu is offline   Reply With Quote
Old 10-07-2008   #3
Eatsbrains
Junior Member
 
Eatsbrains's Avatar
 
Join Date: Sep 2008
Posts: 54
Default Re: X-Perl Thread

Posted new ticket here on WowAce with applicable error logs regarding bugs in r181 being produced on live. Let me know if you need anything else from me regarding these errors.
Eatsbrains is offline   Reply With Quote
Old 10-08-2008   #4
Zeksie
Senior Member
 
Join Date: Mar 2006
Posts: 292
Default Re: X-Perl Thread

Quote:
Originally Posted by tenchu View Post
No complaints here!! Sweet mod.

One thing is that it's possible to make the party player frame as 2X2, 1X4, and 4X1? No biggy if it's no possible.
It's possible I suppose, but would have to do something funky with their pets.
Zeksie is offline   Reply With Quote
Old 10-08-2008   #5
Zeksie
Senior Member
 
Join Date: Mar 2006
Posts: 292
Default Re: X-Perl Thread

Quote:
Originally Posted by Eatsbrains View Post
Posted new ticket here on WowAce with applicable error logs regarding bugs in r181 being produced on live. Let me know if you need anything else from me regarding these errors.
Nah. fixed with r183. Didn't test when LibHealComm wasn't present.
Zeksie is offline   Reply With Quote
Old 10-08-2008   #6
tenchu
Junior Member
 
Join Date: May 2007
Posts: 70
Default Re: X-Perl Thread

I see. The reason I asked is because I use mouseover macros and I place the party frame close to my action bar which is on the bottom. The party frame is a bit tall for me to have it on the bottom and not blocking some of my buff and debuff timer bar that's located next to my IceHUD. Not sure if that makes sense?
tenchu is offline   Reply With Quote
Old 10-09-2008   #7
Zeksie
Senior Member
 
Join Date: Mar 2006
Posts: 292
Default Re: X-Perl Thread

Quote:
Originally Posted by tenchu View Post
I see. The reason I asked is because I use mouseover macros and I place the party frame close to my action bar which is on the bottom. The party frame is a bit tall for me to have it on the bottom and not blocking some of my buff and debuff timer bar that's located next to my IceHUD. Not sure if that makes sense?
Will have to think about it, it's gonna be a bit awkward to fudge that with the pets anchored where they are, and not have it look shitty.
Zeksie is offline   Reply With Quote
Old 10-10-2008   #8
Zidomo
Amazing Member
 
Zidomo's Avatar
 
Join Date: Jun 2005
Posts: 1,179
Default Re: X-Perl Thread

r187 has a problem that makes it unusable here; r178 worked fine.

WoW 2.4.3 live, USEng client/server, LibHealComm-3.0 & LibQuickHealth-2.0 installed standalone. Every time I cast a heal on someone using either Clique or the standard way via targeting/click spell icon, the health text on the health bar "flips" quickly between showing it properly and showing a percentage number instead. As in showing "14000/14000" on one hand and "100%" on the other. Happens as the health increases or decreases every time a heal is cast at the target.

Sometimes the "100%" number improperly shows up for an extended period of time on the health bar after combat is over and the person is at full health. Later, the proper values show up again, but start "flipping" again as above. It happens with the numeric health text & the right-side percentage Party options checkmarked. Also happens when the right-side percentages are disabled.

So far the "flipping" occurs on both the party frames & target frame (have not raided since the weekend). Its very, very distracting & did not occur with r178 (assume its related to the new LibHealComm-3.0 features).

Last edited by Zidomo; 10-10-2008 at 02:59 AM.
Zidomo is offline   Reply With Quote
Old 10-10-2008   #9
Zeksie
Senior Member
 
Join Date: Mar 2006
Posts: 292
Default Re: X-Perl Thread

Quote:
Originally Posted by Zidomo View Post
r187 has a problem that makes it unusable here; r178 worked fine.

WoW 2.4.3 live, USEng client/server, LibHealComm-3.0 & LibQuickHealth-2.0 installed standalone. Every time I cast a heal on someone using either Clique or the standard way via targeting/click spell icon, the health text on the health bar "flips" quickly between showing it properly and showing a percentage number instead. As in showing "14000/14000" on one hand and "100%" on the other. Happens as the health increases or decreases every time a heal is cast at the target.

Sometimes the "100%" number improperly shows up for an extended period of time on the health bar after combat is over and the person is at full health. Later, the proper values show up again, but start "flipping" again as above. It happens with the numeric health text & the right-side percentage Party options checkmarked. Also happens when the right-side percentages are disabled.

So far the "flipping" occurs on both the party frames & target frame (have not raided since the weekend). Its very, very distracting & did not occur with r178 (assume its related to the new LibHealComm-3.0 features).
Yes, I know about this, and I've spent 9 hours over last 2 days trying to figure out how and why it's doing it. Still working on it.

Although I think your 'unusable' statement might be overstating the mark a little

But it is a high priority for me.
Zeksie is offline   Reply With Quote
Old 10-10-2008   #10
Zidomo
Amazing Member
 
Zidomo's Avatar
 
Join Date: Jun 2005
Posts: 1,179
Default Re: X-Perl Thread

Quote:
Originally Posted by Zeksie View Post
Although I think your 'unusable' statement might be overstating the mark a little

But it is a high priority for me.
Great.

The phrase was "...unusable here" . Which it is for me. Some other people may not find that behavior so distracting.

Hope you are able to solve it.
Zidomo is offline   Reply With Quote
Reply

Tags
raid frames, raidframes, x-perl, x-perl unitframes, xperl, xperl fu_bar "dual specs"


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:16 PM.